Feedback - Bug Reports

I’ve found a way to make my auto commit script more robust, so I will probably not be detecting as many mismatches from now on. I feel a bit bad when I bug you guys with such minor things, haha

4 Likes

Grammar point 251 example sentence 770
Corresponding study question is lacking some furigana

image

5 Likes

@Kumi

Every change made, no matter how minor, helps us make Bunpro more enjoyable for everyone.

All fixed! We really appreciate you taking the time to let us know about issues with the site and for making such awesome scripts. Cheers!

6 Likes

I’m having some weird issues with the search feature. Some grammar won’t come up when searching (ex: ように won’t show ようにいう), and ctrl-clicking to open in new tabs sometimes replaces my search with other grammar instead of opening the tab. (Seems to happen on grammar that doesn’t glow when hovered over?)

Using latest Chrome on Win 10.

4 Likes

The problem is that what I am reporting is merely differences between study questions and the corresponding example question. I don’t think anyone is likely to notice or be bothered by them being different. Unless of course it’s something like missing furigana, of course.

2 Likes

Grammar point 715 example sentence 7479

Example sentence says to exclude の

Study question includes it

6 Likes

Look at @Kumi go, making the site consistent everywhere. What a beautiful thing :sob:

5 Likes

Same here on mobile browser (Android)

3 Likes

Grammar search: page (mobile browser) still needs around 20 seconds to completely load (tested with different phones in different countries). Besides that there’s one annoying bug:

While the page is loading, the keyboard pops up for a few seconds, then disappears again and the page continues loading for many seconds. If you could just manage to let the keyboard stay active, users could already input the search term and save a lot of time.

That should be a small fix and would make the grammar search way faster.

4 Likes

Potentially related to the revisions to the hint system, I find that the div with class sentence-nuance is sometimes displayed when the review question is loading, but then hidden (as I would expect it to be per my settings - review English is set to “Show”.)

Is it possible the div is having its style stripped as part of the page load (to then be replaced with an appropriate style per user settings) and this is why I am seeing it flash up?

3 Likes

Not sure if this is a bug. It seems the 10 streak badge doesn’t want to move from my profile page. Should it be 30 days streak?

3 Likes

You can select the badge that’s displayed yourself! Click on any badge in the badge screen (Profile->Badges), and it should be marked (it’s name gets a colored background). That’s the one that’s displayed on your profile – I believe :slight_smile:

8 Likes

Bug reports in Study mode (the feedback button for the general grammar point) lead to a 406 error page. Are those bug reports coming through?

2 Likes

@Anthropos888

Yes, we are still receiving those reports. We are looking into what might be causing the issue. @conan We also have a fix ready for search that we hope to push soon. Thank you for your patience. Cheers!

3 Likes

Just a tiny little thing but hey ho :joy:

5 Likes

The new quiz info screen is a “bit” too big for mobile screens:

3 Likes

Is there no 50 day streak? Or did something go wrong?

2 Likes

There is a badge for 60.

4 Likes

Ah, that would be the problem then :sweat_smile:

2 Likes

Screenshot%20from%202020-02-25%2010-28-06

… after manually adding two grammar points. Previous state: 0 reviews. State on entering reviews: 2 reviews (no more “NEW +3”). Possible cause: I impatiently clicked “Add to reviews” more than once on the second item I added, because it didn’t seem to respond.

2 Likes