Application Error [Bug report]

The page you were looking for doesn’t exist.

You may have mistyped the address or the page may have moved.

If you are the application owner check the logs for more information.

This happened several times when:

  • trying to start reviews
  • after reviews when the results were saved

My review progress has been lost two times too.

5 Likes

I’m having the same issue, and I just emailed their feedback team. I’m hoping the website’s just down for an update and will be back in a few hours.

1 Like

I’m having it as well :frowning: Also not sure if it is actually saving all my reviews. After the first time I had 4 reviews that were the same as in the previous review sessions, and now I have a review session of 1 which also has the same review that was in the 4 review session.

1 Like

I’m having this issue as well. When I finally do get the reviews to load it goes in a cycle of showing me the same reviews repeatedly. It’s just not saving them at all.

1 Like

Since yesterday I’m also seeing this error. However, I can’t seem to load the reviews at all. The page just freezes on ‘Loading reviews!’ and after some time it just crashes. Hope this is just temporarily and that it will get fixed soon!

2 Likes

Had issues last night, fine during the day, issues again tonight. same error.

1 Like

+1

hope it gets fixed soon

1 Like

To be honest, considering people are paying for the app now, they should be more forthcoming with problems like this. Still no announcement as far as I can see and I’ve wasted time doing reviews that didn’t save.

2 Likes

It was fine all day for me (I live in Japan, so I guess that means fine all evening/night in the US), but after 5 pm JST the reviews stop loading and using the site to study becomes impossible.

2 Likes

The error only seems to occur between 9:00-13:00 GST. Your progress before the error is saved, but you can’t access the site, do reviews, or save notes/self-study sentences while the site is down. Today is the second time I had a problem, but everything is fixed after a couple hours. If you can, wait to use the site until after this time if you need to go through bulk reviews for now.

1 Like

Same problem here in CDT. Guess I should have done my reviews an hour or two ago.

Edit1: Looks like its working, I just did my reviews.

2 Likes

@amelcr2 @Kuokukakudaku @LonelyMountain @Fumoffu (is this reference to full metal panic?) @Kuromaku @johanols @Pep95 @johanols @coverly @daftdrunk

Hey (and welcome on community forums!)

I have contacted the technical part of the team about the issue!

Sorry for the inconvienience :bowing_man:

2 Likes

@Kuromaku @amelcr2 @Pep95 @LonelyMountain @johanols @coverly @daftdrunk @Fumoffu @Kuokukakudaku

Hey everyone. I apologize for the frustration!! I spent the last day and a half working on this bug, I know exactly what is causing it (namely somehow it is possible to get negative XP causing the app to crash) but I haven’t been able to pinpoint where the logic is flawed letting it happen.

It is actually the same bug that happened a couple of days in a row earlier this spring causing the same error to appear. I thought I had fixed it since it hasn’t happened since then…I guess not :confused:

I am planning on getting a patch up that will at least check for, catch and fix the issue for now and will keep searching for the bug afterward.

Thank you for your understanding and thank you to everyone who provided feedback!

11 Likes

@BunproAdmin sadly, I still get random crashes from time to time. Even when just opening lessons tab, not just reviews like before.

1 Like

Glad to see you are already working on the issue.

Thanks for your work on this! :smiley:

2 Likes

Seems like I can’t even access the lessons page:

https://www.bunpro.jp/grammar_points opens normally though.

3 Likes

Maybe related to what @mrahhal posted?

@mrahhal Sorry about that. We added more new grammar which messed up the existing grammar ordering on the lesson page :confounded: It has been fixed.

4 Likes

Hey all, I’m not sure if it’s an application error or not but I can’t seem to turn back on auto renewal. It says my subscription will expire August 20th (yesterday.) So I can’t seem to get it to bill me to resume studies.

When I select “On” from the dropdown menu and press Update, the button changes to a blue “Updating” and a loading circle icon that will keep spinning and spinning until the end of time. :stuck_out_tongue:

Capture|474x161

Just thought I’d check in real quick. Thanks!

1 Like

@Pushindawood

And it happened again :slightly_frowning_face:

bug

This is what I see after doing reviews.

In a fit of irony I got an error looking at this thread :joy: