Bug Fixes and Adjustments - 8/30

Hey everyone! Like mentioned in the previous update thread, going forward we’d like to compile most of the fixes we make behind-the-scenes to give you a better idea of what’s going on in our world. A lot of these things you may have not even realized were ‘wrong’ or broken, but we feel it’s still worth pointing out.

Bug Fixes/Adjustments:

  • Fixed an error where the Male audio was not playing properly during cram & review sessions.
  • Allowed for the 700-day streak badge to actually be obtainable.
  • Fixed an issue where an N4 grammar point went rogue and escaped into N3 making the jlpt progress calculation incorrect.
  • Adjusted how the cursor functions in reviews. Previously you would have to re-click the input field after using any of the sentence pop-ups; however, that’s a thing of the past!
  • Fixed the correct JLPT level being shown during cram.
  • Solved an issue where vacation mode wasn’t interacting and leaving users with a pile of reviews upon turning it off.
  • Fixed an issue where when the new ‘auto-expand’ feature was enabled, it would expand at the wrong times like a hint showing, etc. Safe to re-enable this now!
  • Fixed an error where the reading passages in JP mode had an odd interaction with the show translation button.
  • Slightly adjusted where the “NEW!” appears in Grammar_All for the time being.
  • Solved the problem of Grammar points in the search area not being 100% clickable that leads to a new page opening up
  • Made the SRS tiles on the dashboard more clear that they’re clickable
  • Plus some super tiny text coloring/alignment adjustments that are truly not that exciting nor interesting.

As always, thank you to everyone who takes the time to use Bunpro and put it to its absolute limits so we’re able to see specific instances where things may not be working correctly!

Stay tuned for our next update or bug fix thread!

36 Likes

Not sure if it is addressing this, but if the 4th point is about allowing you to use the “Enter” key to move to the next review instead of repeatedly waking up the cursor and moving it to “Next” or whatever and clicking that to be able to access the next review, that’s much appreciated because just pressing “Enter” is so much better/easier/quicker, thanks! :slight_smile:

7 Likes

I really appreciate all your hard work. Bunpro has been a real life changer for me. I wish it existed back when I was (painfully) studying japanese at university.

Also, I was wondering if you guys know approximately when you will be releasing the grammar explanations for N2? I will be done with N3 next month and I’d much rather read your explanations than the ones from other websites. :nerd_face:

4 Likes

I’ll repost this from a recent thread where it was asked! Asher can chime in if he has anything else to add, but hope that sheds some light for ya! Glad to hear Bunpro has had such an impact for you!!

4 Likes

Regarding the cursor function during reviews, for the last few days I’ve noticed that after every few answers I complete, the cursor disappears and I have to click back in to the entry field. I couldn’t quite figure out if it disappeared on its own or if I had clicked on the hint button before typing in my answer.

Just so I understand correctly:

  • Doing reviews like normal
  • Going from question to question
  • Suddenly when you go to a new question the cursor is no longer automatically inside the input box and you manually have to re-click it

Is that about right? If so, can you just keep a note of whether or not this still happens after the recent changes we made to the input box? Shouldn’t have impacted that and I haven’t seen it on my side yet nor during testing buuuuuut this was a problem we had ages ago, looks like it might be worth re-opening the vault.

Either way, thanks for bringing it up! Based on your comments I’ll do some deeper digging and either myself or someone from the dev team will reach out to gather more feedback. :bowing_man:

@EdBunpro Yes, that’s exactly it. Chugging merrily along, and all of a sudden I press enter on a review I thought I typed in (but I didn’t actually because the cursor went on a journey and I didn’t notice) and I get the “please type your answer in the box” message.

It happened in the reviews I did about 10-20 minutes ago, as well as yesterday morning. I think it happened on Sunday too, but I’m not 100% sure about that.

I’m thinking the backspace key might also be a factor. I know I backspaced out of one or two answers for typos.

1 Like

Gotcha! Considering we solved this bug once before, hopefully re-fixing it isn’t too big of a pain. Thanks for the detailed explanation, it’ll get investigated tomorrow for sure.

I’ve noticed this happening for the last few days. Show Vocab Info pulls up the wrong vocab/grammar point.