Custom Sentence weirdness

I love being able to add Custom Sentences. Someday Bunpro data analysts are going to check why the sentence table in the database is so big and underperformant and realize it’s all my fault and charge me accordingly. I’m crazy slow, I take forever to add new grammar, because I fill each grammar point with Custom Sentences. But I’m noticing some Custom Sentence and Cram weirdness that I thought I’d call out - these might have always been there, or maybe I’m just noticing now because GUESS WHO HAS TWO THUMBS AND MADE A NEW YEAR’S RESOLUTION TO GET HIS BUTT IN GEAR ON NIHONGO AGAAAAAAIN or maybe just I’m a boomer.

  • I think I never noticed this before, but Custom Sentence questions are not included on Cram. Is that by design? Is there a way to include your own Custom Sentences when cramming that I’m missing?

  • I’m noticing that some audio that is present on the Grammar Page isn’t playing on Cram (no idea if it’s also not playing on regular reviews). I have ‘Autoplay Audio’ set in my settings, but it looks like it will only auto-play if there is Female audio present. A sentence like this blue-selected one in けど which only has Male voice won’t auto-play during Cram reviews (don’t know if it would during regular reviews):

  • I can’t figure out how to get furigana to work reliably anymore in Custom Sentences. The directions say to use Japanese (), and I’m fearful that my old sentences reverted? All my old sentences look weird now, but I can’t Cram them and test it:


    And here’s a newly added one, same thing:

    Maybe it was always like this? I feel like it wasn’t always like this. But maybe it was?
    But I hoped it might just be the Example Sentence screen, but I’m getting mixed results in the Reviews screen. Sometimes it properly changes the parenthesis-kana to furigana, sometimes it keeps the parenthesis-kana on display. I notice that after saving, the “____” will get < span > tags with a class attribute if you re-edit your sentence; does something like that supposed to happen on parenthesis-kana too?
    Edit - I spent the morning putting in bunches of sentences, and the furigana is working as usual. So I was probably just being a silly goose. /Edit

(I will also humbly suggest that it is also possible (probable) that I’m as incompetent at using BunPro as I am at Nihongo in general, and that the furigana is working exactly as it’s supposed to.)

2 Likes

Thanks for the feedback! You are correct, custom sentences do not show in cram.
For now the audio in cram (and in reviews) is just the female audio. Once we have the male audio done for more sentences and a few sentences rerecorded on the female audio side, we will add a male/female audio toggle to reviews/cram.

At some point we plan to overhaul the custom sentences. I think they are usable but could be a lot better and hopefully we will be able to make the creation process and tools for them more powerful.

5 Likes

I’m getting a bit of custom sentence weirdness too. I’ve searched but can’t find an answer to this. Take a look at the two sentences below, both in the grammar point for ‘う-Verb (Past)’. The first is formatted just fine, the second is weird. The space for the answer isn’t showing up. I’ve typed, and re-typed. Is it just because it’s too long or something?

Screenshot 2022-11-20 4.33.20 PM

2 Likes

Did I make a mistake here? Should I have made a new thread instead of bumping an old one? Not quite sure of the etiquette. Sorry.

2 Likes

I tried to see if I could reproduce the issue. Furigana doesn’t seem to work at all for me. As for the missing answer space, I think it’s automatically formatted upon saving it the first time (see the span class thingie below), which means that editing it later won’t add it automatically.

image

Try adding <span class='study-area-input'>____</span> where the answer space should go instead of just the four underscores. It worked for me.

Forum is usually helpful, but people don’t always respond which can be frustrating. Making a new thread usually garners more views which increases the likelihood of someone posting a reply. I don’t really know the etiquette here either, I’m used to the WK forum. Maybe because there’s much more traffic there it’s easier to get a response. Time could also be a factor.

Site statistics for both WK and BP communities

WK:

BP:

3 Likes

Truly, you are a genius! Thank you so much! That is really useful! I’ll remember that for the future! Much appreciated.

Furigana only works for me if I type the round brackets while in Japanese typing mode, if I type them in English typing move, they don’t work.

And those stats are incredible! Thank you for that! (Though I suspect over time they will change, as more and more people start using Bunpro!)

Thank you so much @Redglare !

3 Likes

This is definietly a bug, I’ll have the dev team take a look at this. Thank you for reporting this!

2 Likes

@Redglare @Marcus

Thanks for the feedback, and good discussion guys!

For the ‘____’ issue:

The User Study Question system is a bit fragile at the moment, especially with the four-underscore system. One incorrect input can break a whole sentence.

Unfortunately until we get it fixed, I would suggest deleting the entire sentence and recreating it if you can’t get it to work.
I think manually adding <span class='study-area-input'>____</span> will potentially break it even more.

For Furigana:
Yes the parenthisis need to be full-width () vs ().
I’ll add a translation for this now so now one else runs into the same confusion!

Lemme know if ya’ll got any more questions :v:

3 Likes

Thank you for looking into it! You mean, if I add that thingie (I don’t know what to call it) the whole system could break?! It’s weird because when I do add it it, it works. I’ve only had problems with this single sentence.

Edit:

Well, I did that, and, guess what… it works!

Blimey, no idea what I did wrong first time round! Sorry to be such a pain! Thanks so much again @Redglare and @veritas_nz for your help!

1 Like

Thank you for looking into it! You mean, if I add that thingie (I don’t know what to call it) the whole system could break?! It’s weird because when I do add it it, it works. I’ve only had problems with this single sentence.

Yeah I’m not exactly sure on the BTS workings of the User Study Question system, but looking at the code it looks like it find/replaces all instances of ____ with <span class='study-area-input'>____</span>. So if you manually entered it with the HTML already there, you would get it double nested (<span class='study-area-input'><span class='study-area-input'>____</span></span>).
Until we get this sorted I think the safest way is to delete and try again! But then again you were saying just entering ____ doesn’t work so…

Blimey, no idea what I did wrong first time round! Sorry to be such a pain!

No need to apologize! It’s us that should be apologizing for the bug existing in the first place :sweat_smile:
But thanks for the feedback! And hopefully this solution works as a stop-gap until we release some bigger updates in the near future :v:

1 Like

Ah, but it did work when I took your advice and deleted and tried again! I have no idea what went wrong first time around. My apologies and thanks once again!

2 Likes