Bunpro reviews seem completely broken now


I’m having a huge problem right now with the Bunpro site itself.

Whenever I do reviews, and get one wrong, the incorrect grammar point description is coming up underneath the answer box. This basically makes the site unusable for me. Has anyone else seen this specifically?? I feel like I see the site break in a variety of ways everyday, but this is the first time it’s made it genuinely unusable.

Next, whenever I do my last review available, the screen saying there is an internal server error comes up, then I have to go click on the homepage button to get back.

Finally, when I opted in to the Beta and review 2.0, it changed the layout of the home screen. Then I opted out, and the layout (grammar + vocab reviews buttons and some other stuff) didn’t change back. Then today I tried to opt back in to get the more aesthetically pleasing review screen that I used several days ago, and it won’t come up again. This doesn’t make the site unusable, but it makes it very confusing. I’m not sure if I’m missing something, or what.

I imagine nobody has a super easy fix for this, but in case I’m wrong I want to try to get some answers before I ask for a refund. I like the idea of the site overall, but it rarely functions as expected. I like learning grammar points with an SRS system, and I’m not totally sure of other options for that.

Has anyone else come across other good ways (besides just brute force studying, which I do as well) to learn grammar, or other SRS grammar options??



Go into your setting under General - Reviews and turn off Auto-Expand Info. Should stop the autoplay.

1 Like

Hi there! Welcome to the forums.

For the first issue, as @SteveDoesJapanese mentioned (wrong answers displaying Grammar Point info), you are likely using the “Auto-Expand Info” setting.

As for the Beta Reviews screen changing, this is likely due to the fact that we’re changing how it looks based on user feedback daily (discussion is in the bottom of this thread).

As for the layout of the home-screen (Dashboard), are you able to remember roughly what didn’t change back? And what the difference between the two states were? I’m not personally familiar with how the internals of the Dashboard work, but I’m guessing it could be something to do with the ‘Split Reviews’ option under Settings > General > Reviews.
Anyway, let me know the above and we can look into it for you.

Sorry for the inconveniences :bowing_man:


Thanks for reaching out. Sorry you are experiencing those issues.

Regarding the dashboard, the only way the layout changes is via settings. Nothing in beta or reviews 2.0 impacts the dashboard. There is a “Split Reviews” setting that you might have toggled which would change the layout though.


Thank you everybody! I appreciate the replies.

I went in and changed the split reviews to ‘No’, and I think that may have taken care of most of what I was seeing in the homepage layout? Unfortunately I don’t have any before/after screenshots etc. over the last week or so, so I don’t remember 100%. I feel like the ‘Decks’ button in the nav bar was not there before I opted into the beta, but stayed there when I opted out again. Maybe I’m completely imagining that though, and also it doesn’t particularly matter!

Overnight, the look of the review screen seems to have changed back to the 2.0 colors I had seen several days ago or so? Not sure if that’s the updates veritas_nz is talking about or what, but it seems to be working!

I’m not sure about the ‘auto expand info’ causing problems. I have left it on, and I’m not seeing problems after doing several reviews with 2.0 reviews. When I do more later today I’ll see if there’s still problems even when using the 2.0 reviews, then try switching that off and see whether or not things are solved.

Finally, I haven’t gone through all my reviews to see if the internal server error page comes up, but I’ll chime back in if there’s issues with that.

Thanks again everyone!


Just a final update!

I still have the ‘auto expand info’ setting on, but it doesn’t seem to be causing problems with 2.0 reviews, so I’ll be keeping it on for now.

Also, I’m not getting the internal server error screen when I finish reviews.

So I guess I’ll chalk it up to Reviews 1.0 bugs for now?? Shrugs

Thanks again!

1 Like