Feedback - Bug Reports

I have to wonder…is there some kind of scheduled task that hasn’t been running lately? My subscription lapsed three days ago and I’m still able to do reviews. In this thread we see achievements staying locked, and in another thread people are finding that their paid subscriptions aren’t unlocking.

1 Like

I’m trying to make a self study entry, but the English is repeated 4 times on the edit tab and review. Only the last line shows the highlighting. If I delete the English and save the entry I get a quick flash in the input box of the other text with some HTML but can’t see how I can access it to delete it.

Edit: My error, I see what happened now. That input is actually a multiple line text editor, so allowing it to expand to fit the content would be more helpful. When I’ve pasted in the text from elsewhere it included a carriage return and I thought it didn’t paste because the text scrolled out of the visible area. So I’ve pasted it multiple times thinking that it wasn’t working.

1 Like

@Kai, @conan, @matt_in_mito, @Kuromaku Thank you all for your reports. We are looking in to what might be the issue with the Exorcist III badge. Thank you for your patience. Cheers!

@jacobalbano We apologize for the confusion. There is actually a two-day grace period for those using the trial to decide whether or not they would like to subscribe and a four-day grace period for subscribers to renew their subscription. This not only allows you to get the most out of your trial/subscription, but allows us time to manually update accounts where users have subscribed through PayPal. ¹

From the FAQ:

With PayPal, we have to manually process payments which can lead to a delay between when you subscribe and when we can apply it to your account. We usually are able to take care of this within an hour, but sometimes it can take up to a full day.

We appreciate your concern and hope to see you back soon! Cheers!

¹This is for users who are subscribing with PayPal for the first time or have auto renewal turned off

@Kokusaibu Thank you for your suggestion! We will see what we can do about making the Self-Study forms more intuitive/expandable. Cheers!

Edit: Updated information about PayPal for clarity.

4 Likes

Using the Firefox Stylus extension I’ve changed the .wysihtml5-sandbox class to max-height: 70px and height: 90px which works well for me. It shows a few lines and the scroll arrows appear if you type more. It’s actually handy being able to use multiple lines for the English explanation.

Also there are some login issues due to both the www and non-www subdomains being in use. Consider redirecting all requests to one or the other.

For example, as suggested by Google search results I’ve been using www.bunpro.jp

But on the Review pages, the links to the related Lesson are the full non-www URL https://bunpro.jp/grammar_points/*** when they ideally should be relative URLs like /grammar_points/***

When clicking those links the user is requested to login again, this time via the non-www domain.

3 Likes

Hey, developers, for the last week and a half or so, my almost daily problem with getting answers counted as wrong when using the backspace button to correct has totally disappeared! It hasn’t even happened once! I’ve done nothing myself to alleviate the problem, so have you guys done magical things in the background, or is this divine intervention? :slight_smile:

1 Like

It seems my streak was lost over night? I had 60-something going but I come back today and see I am back to 1. I looked at my browser history from yesterday and it shows I did my reviews, but if it look at my stats it shows I didn’t.

2 Likes

There was a time change recently. Perhaps that’s related?

2 Likes

I know that pain…

Is it possible that all of yesterday’s reviews were ghost reviews? :thinking:

I couldn’t tell you if they were ghost reviews or not. Does that make a difference?

They don’t give XP so I think they don’t count, but I could be wrong about that.

The FAQ doesn’t really say in the Ghost Reviews section:

@Kokusaibu Thank you for providing this information! We will see what we can do about implementing it into the site. Cheers!

@1112 Hey! We actually haven’t had a chance to push the changes/bug fixes that we thought might be associated with the problem yet. So, while we would like to take credit for performing magic, this seems to be divine intervention. Please let us know if you experience any more issues. Cheers!

@MasterOfPuppets As @conan suggested, it looks like the recent time change may of been the culprit. I have restored your streak. If you wouldn’t mind confirming/saving your time zone in your settings to account for the change, it will hopefully prevent this from happening in the future. Thank you for your patience. Cheers!

@Momiji

Any review that you do on Bunpro (regular reviews, Cram reviews, Ghost reviews, or Self-Study reviews) counts toward your streak. As long as you are doing some sort of review/cram on Bunpro you will not lose your streak. Cheers!

4 Likes

Indeed my streak has been restored! I confirmed my time zone was correct, but clicked save at the bottom of the page again anyway. Thanks to everyone who had a hand in fixing it!

3 Likes

You gotta do something about the login cookies on mobile. I forgot to select the “remember me” checkbox when logging in, resulting in me getting logged out within about an hour. There’s really no reason to ever log someone out of a website like Bunpro.

I’ve tried scrolling through looking for this bug - im sure it has already been posted -
Once the audio gets played, the play button disappears. you have to hover where it used to be and guess where to click - it works then :slight_smile: it happens on all devices, apply, android and windows

1 Like

Hello!

I’m having a really specific issue with loading the Genki I 2nd Edition grammar path. Whenever I go to study a specific chapter, it loads the first grammar point and then freezes. Whenever I try to click to the next grammar point, it gets stuck on loading and then the freezes. I’ve tried navigating other chapters and it’s much the same. Although when I click on a smaller chapter with fewer grammar points, it loads eventually, but takes a while. I’ve navigated the other parts of the site to see if my connection was bad, but everything else seemed to work fine.

I’ll be checking back soon to see if it’s just an intermittent issue on my end, but until then, I just thought it would be worth mentioning!

2 Likes

I have furigana showing up in weird places. In both examples pictured below, you can clearly see another place for the same word where the furigana (appropriately) does not appear.

In the structure:


In the hint under a sentence:

2 Likes

In Profile/Stats tab/November and December are truncated on the right.

1 Like

Tiny bug: when you go from one section of a grammar page to another (e.g. examples to readings), sometimes the page jumps back to the top (desired behavior, for me), and sometimes it doesn’t, though I haven’t figured out why the behavior is inconsistent.

2 Likes

I’m sometimes getting a long database dump instead of a Review page when using mobile. I thought it may have been when I switched tabs part way through a Review session, but it just did it again immediately upon clicking Review. I’m using Firefox.

reviews

1 Like

Small annoyance in the kana input field: when a character is converted, the cursor jumps to the end. Example UX issue caused by this:

  • I got a question that should be answered with それでも.
  • I entered でも and was prompted to add something.
  • I pressed <Home> <S> <O> <R> <E>, expecting it to result in それでも. However, after the first three keystrokes, my cursor was at the end, i.e. そでも| instead of そ|でも. After the other two keystrokes, I ended up with そでもれ, which is obviously not what I intended to write.

This is on Windows, Chrome 78. Not a huge issue, but since I often end up writing an approximation first then fixing it up before submitting, it pops up pretty frequently.

2 Likes