Feedback - Bug Reports

@flatstan @hx9 @Ayla @amberglade @c1

Hi all!
I’ve attempted a fix on the Forecast daylight savings bug.
Please let me know if it’s fixed for you!

1 Like

Unfortunately the issue persists. I’m sharing a screenshot of my deck settings, if it helps:

As you can see, I have them set to “Translation Questions/Manual Input” yet I keep getting the self evaluation questions on new words. The exception is the N3 Deck is set to Cloze, but that one is working fine. My issues are with the N2 and N1 Decks. I have to click the button at the bottom every time after adding the new words in order for the settings to apply to them.

Another thing I’m doing is I’m opening 30 tabs, one per word, so that I can study them before I start the SRS process. Just mentioning it in case it matters.



Welcome back to the forums. This should be fixed now!
It was a weird negative number bug.

1 Like

on the mobile app, it says I’ve completed everything and I can’t learn anything new when I literally just started but it only does this on mobile not desktop for some reason. I’ve made two accounts to double check and it’s still doing this so idk what’s going on. I just click learn on the mobile app and this pops up and it just keeps showing this menu all the way up to N1 and just repeats the cycle so you can’t learn anything.


I encountered a strange bug when using Bunpro on PC today. I’m using Google Chrome as my browser. From the dashboard, my daily learn goals use the wrong decks.

Currently, I’m learning using the N5 Grammar Deck, N5 Vocab Deck, and the N4 Vocab Deck. However, on my dashboard it shows up as N1 Grammar Deck, and it says I’ve finished the N5 Vocab Deck. Visiting the decks page, everything looks fine. I did try deleting and re-adding decks to my learn queue, but that didn’t seem to help.

If I start my learn queue from the decks page, that batch of reviews is fine, but it tries to make the N1 deck my next item in the queue.


Getting a lot of weird things on decks, including it saying I’m most of the way through N1 Grammar, when I actually haven’t started it, and saying I’ve done way more than the total possible number of items in N5 Vocab (which somehow became my secondary deck for some reason, despite finishing it long ago):


Can you please visit that Deck’s page and tell me what happens?

Other users are reporting this bug too.

@RKstudios @tanglechuu @Mexiken @Airibun @SoulSearchingPuppet

Should be fixed now!


Yep, seems to be working again!

1 Like

Another thing I’m doing is I’m opening 30 tabs, one per word, so that I can study them before I start the SRS process. Just mentioning it in case it matters.

Ahhhh that solves it then…
In this case it matters a lot!

Reason why it's seemingly broken

If you open a Vocab/Grammar in a different tab, it forgets what Deck it was part of, so when you add it to your Reviews, it will use your global default (for you, it’s Cloze).

Will discuss this with Jake, but might be as easy as adding a ‘source’ to the URL (e.g. /vocabs/日本?deck_id=8), so that when adding it to Reviews, it knows which Deck’s settings to use.

And actually now that I think about it, you already told me that you use the Vocab Search feature, which will also open stuff in a separate tab with no Deck content :thinking: :sob:

Anyway, in the meantime, unfortunately you’ll have to add these items manually using the Add to Reviews button on the Deck’s individual page.

1 Like

Hey @EnvyWitchh!

We are working on the fix which will be released soon!
At the moment, you can fix it by going to content tab → decks and tap on deck you want to learn then in the window that opens tap on “gear” icon and select this deck as “main”. Now go to the dashboard and learn button should be working.

It should fix the issue for the time being before we push the update!

Cool Bocchi avatar!


Awesome! Glad you were able to figure it out :+1:.

While we’re on the topic, it would be nice if in the future you guys could add a way to review vocabulary without needing to leave tabs open. Especially when there’s several words, it gets a bit messy. Perhaps you could provide an extra option that allows us to add words to a queue where they can be all reviewed in succession. It could be a button below the “Add to Reviews” button, or something like that. Something as simple as the current review system, where items are added to a queue, but with all the word’s info and without going through the SRS. Perhaps it could be a “Study” button, so we can first study them, then we can add them to the SRS with an “Add All to Reviews” button. Might actually be nice to have this feature for Grammar points as well.

The reason for this feature is because I don’t personally go by the BunPro order, but my own. I find it much easier to learn grammar/vocabulary that are relevant to what I’ve encountered while consuming content, than by some random list. However, I also add items that I feel might be easy because they’re similar to other stuff I’ve learned before, but because it takes time for me to curate this list of items, I find that leaving the tabs for each item open in my browser to be the best solution I’ve found. However, it’s not very convenient to have 30 tabs open, plus whatever other tabs I had opened from other sites, so this would be a nice feature to have.

Hopefully I’ve explained things correctly. I think this would be a huge improvement to the current workflow.


1 Like

We’re discussing this currently! :tada:
Will maybe take some for of custom user “Quick-Study Queue” Deck, once we implement user Decks.

1 Like

Yes, a Quick Study feature sounds great!!


1 Like

I think this has been fixed. Thank you.

My forecast now starts at 6:00 a.m. (it is currently 6:50 a.m.), where it would start at 5:00 a.m. before the fix.

1 Like

[Edit: I’ve now read a bunch of previous reports which mention the same basic bug. I believe my report may have additional detail and reproduction steps to isolate the edge-cases and locate the underlying bug(s). Hopefully. :sweat_smile: But, as of right now, this bug/issue is still a thing. In particular, I think the Side-Bug I’ve mentioned below might be a key issue; perhaps it is the main underlying bug?]

There are several related issues in this comment, so I’m going through the (simplified) bug research process to ensure I get them all. (I don’t know whether this is truly many distinct bugs, each requiring their own fix, or whether they are side-effect bugs caused by a single underlying bug, requiring just one fix.)


When I click [Add to Reviews] on the 分科 Vocab page, it adds the vocab with Answer setting as ‘Reveal & Grade’, even though my default settings are to use ‘Manual’ for Answer.

This has occurred (on other Vocabs) recently several times recently, without my noticing it until they later came up in reviews with the Reveal & Grade style input. I only noticed the cause being the behaviour of [Add to Reviews] just now.

Well, one possible reason is that the default settings are over-ridden by deck-specific settings. So maybe the deck for 分科 has the wrong settings.

The only problem is that 分科 belongs to the A3 deck, which I don’t believe I have access to in order to change its default settings.

So, I checked a random other vocab, 水分 which is N2, and when I [Add to Reviews] it also sets Answer as ‘Reveal & Grade’, even though I double-checked and my N2 deck settings are set to ‘Fill-in Question / Manual Answer’.

So, it looks like this is a bigger issue (for my account, anyway, don’t know if others have experienced this) than just one rogue deck’s strange settings.

I’m guessing now that most, if not all of the recent Vocabs I’ve added have been set to ‘Reveal & Grade’, instead of ‘Manual’.


Furthermore, I went to the N2 deck settings and with the ‘Fill-in Question / Manual Answer’ setting on, I clicked the [Change Vocab to Fill-in Question / Manual Answer] button, and confirmed with [OK]. This had no effect on the 水分 vocab, which remained ‘Translate Question / Reveal & Grade Answer’.

So, I figured, maybe there’s a side-bug that won’t update Vocabs’ settings when the settings are technically ‘not compatible’ with the deck. In this case, since deck N2 does not yet allow for ‘Fill-in’ Question style, so maybe trying to click [Change Vocab to Fill-in Question / Manual Answer] fails because it can’t change the Question style to ‘Fill-in’.

So, just to test if this side-bug is actually a thing, I switched the N2 deck setting to ‘Translate Question / Manual Answer’. Then I clicked the [Change Vocab to Translate Question / Manual Answer] button. This indeed worked :exclamation: , setting the 水分 vocab to ‘Translate Question / Manual Answer’.

So, that side-bug is indeed a thing.

Back to Main-Bug

I still actually want my N2 to remain set as ‘Fill-in Question / Manual Answer’, because I’m waiting for the BP Team to enable ‘Fill-in’ Question styles for N2, which is my preferred style. So, I set that setting back.

But that still leaves the issue with the wrong default of ‘Reveal & Grade’.

And there’s one last bug to report with this.

If I go to my User > Settings > Reviews, I indeed have them set to ‘Fill-in’ Question and ‘Manual’ Answer. So, I tried to use the Update All section’s [Update :arrows_counterclockwise:] button.

After about 30 seconds, an error message briefly appeared above the button, something along the lines of “An error occurred …”, but it always disappeared too quickly for me to copy it.

This error occurred at least 5 times, I think, but as I was trying to reproduce the bug for this report, it finally said “Update Successful” on the latest one, so I don’t know what’s going on there, but maybe you can check the logs of my account’s activity prior to the current time of 12:10 p.m. Wednesday, March 20, 2024 (EDT), to see what kinds of error(s) were logged.

Even after that ‘successful update’, it did not actually change the N2 vocab 水分 to ‘Translate Question / Manual Answer’, let alone ‘Fill-in Question / Manual Answer’

So, this ‘Update’ bug also is a thing.

So, summary:

  1. [Add to Reviews] setting vocabs to ‘Reveal & Grade’, despite that none of my settings are set to that.
  2. Individual decks failing to ‘update all’ with appropriate settings.
  3. User settings failing to ‘update all’ with appropriate settings.
  4. (Any other minor bugs I may have mentioned but can’t recall right now)

That’s all I’ve got for now.

I’ve also run into similar cases. What happened: I was previously adding vocabs from higher JLPT levels before I was really ready for them, but some of them I got up to significant SRS levels, like 8 or 9. Then I decided I wanted to start Vocab over from scratch, once I learned of the (then new) ‘Fill-in’/Cloze type. So, I used whatever was the most obvious UI mechanism (can’t remember what it was now) to ‘reset’ all my vocab.

But what this did was simply to ‘remove from reviews’ the vocabs without resetting their levels to 0, or better yet ‘never reviewed’.

When I later realized that I wasn’t seeing many of the vocabs I had Learned (after the reset, using the new Cloze settings), I looked into them and then figured out that I had to ‘reset SRS level’ on them. I did this manually (bit of a pain) by using the various ‘grades’ (Beginner, Adept, Seasoned, etc.) from the Progress section on the Dashboard, with the Vocab setting to show for Vocabs. I had to click inside each ‘grade’ to show the list for all the items in that grade – in particular for grades such as Seasoned, Expert, and Master), open them all manually in new tabs, then mechanically go through all the tabs to ‘Rest Progress’ on each one.

Was tedious, but luckily only a one-time thing. Since I had made some legitimate progress on some Vocabs, such as some N5s, there was no safe way to use any kind of deck-specific ‘Reset Progress’ (don’t know if that even exists).

My suggestion is to have multiple (clearly identified) options for when a user wants to ‘remove’ or ‘reset’ a Vocab (and possibly/probably Grammar too):

  1. The one most people probably expect to happen: “Remove from Reviews & Reset Progress” to ‘never reviewed’ or level 0 or whatever.
  2. “Remove from Reviews”, which could possibly be renamed to something like “Pause from Reviews”, which ‘pauses’ or ‘holds’ the item from being reviewed, but does not reset its SRS.
  3. “Reset Progress” which sets SRS to 0 or whatever. This can be considered a ‘special case’ of manually selecting the SRS level, and so could possibly be grouped into that UI. (?)
  4. “Mark as Mastered” sets SRS to max (12 I think?), which (probably as a side-effect?) also removes it from the Review queue. This could also be considered a ‘special case’ of manually selecting SRS level.

But, in the use-case where a user wants to ‘start over from scratch’, like a Reset on WaniKani for example (or actually, more like a Resurrect of a Burnt item, but without it having to be Burned first), what they really want is option #1.

Currently, whenever I want to ‘completely remove’ an item from my Reviews, I have to consciously remember to first do a ‘Reset Progress’, to make sure if I ever add it to reviews again, it will start from scratch, and then second do a ‘Remove from Reviews’.

Would be much nicer, less clunky if that ‘intention’ was wrapped up in a single button which did option #1, which is to both ‘Reset’ and ‘Remove’.

1 Like

Unfortunately, if you look at my recent report on the same issue a few posts back, you’ll see that the issue persists even for the A decks (and I imagine also the E1 deck, but I haven’t checked), and these decks are not directly accessible by users. In particular, we don’t have access to ‘deck settings’ for them.

1 Like

Hi everyone. I experienced a bug where grammar & vocab reviews stopped giving me the review according to my previous learning activity, as if I were a new account and never learn anything.

I tried Bunpro free since last February and reached halfway of N5 grammar lists and some vocabs. The Review option works as intended on figuring out which grammar & vocab points I’m lacking so adjust the review quizzes and schedule accordingly.

My free trial expired last week so whenever I tried to do a review, Bunpro will tell me I have no active subscription which is as expected, at this time I had more than 20+ review waiting for me during my Bunpro “Lite” / free and cannot do review unless I paid for subscription.

Earlier this week I paid for the subscription, however once I did that, I have no more review left. It’s been a few days and the review list is still at 0, so yesterday I decided to try to learn 3 new grammar points and now it shows me I have 3 reviews, compared to 20+ back when I haven’t bought new subscription a few days ago. All the grammar & vocab points I have learned are still added to review as per default setting, tested on the app on 2 phones & desktop still have the same issue, so I think it’s an issue with Bunpro backend.

Only thing I can do to review past grammar & vocab is trough the cram feature, however it is not ideal since I don’t know which grammar & vocab point I’m still lacking and reviewing all of them at once periodically takes too much of my time.

Could anyone help me?

1 Like

I am also using kiwi browser (v 124.0.6327.1), on Android 14.

Silly question from someone who doesn’t know web development, perhaps, but why choose such a roundabout way of implementing this setting as to make it dependent on the browser cooperating nicely? Wouldn’t it have been both easier and more reliable to implement the queue order setting like all the other settings under I mean, if I change the Ghost setting there, I don’t need to hope that my browser’s localstorage APIs act nicely…

1 Like