Feedback - Bug Reports


#528

Oh, sure. That’s what I have it set to. What context/setting are you talking about?


#529

Anyone else unable to listen to the audio for the example sentences right now? I tried clearing all cookies/cache/databases for Bunpro. I tried logging in and out. I tried restarting my browser and nothing made the audio work. I use Safari, v 12.0.2 (13606.3.4.1.4)

Edit: My reviews about 12 hours ago had audio. My reviews right now did not. So the problem is not only with lessons. Not that I’m sure it is a problem/bug for anyone but me…


#530

Hey! I have forwarded the issue to the programming team. :grin:

Could you take a screenshot from console (right click in the web browser -> inspect -> choose console tab, take screenshot of it and upload here) just in case?


PS
N3 and N2 examples do not have audio (coming soon :sunglasses: )


#531

Please add links to the forum discussion for every grammar point. It’s easier to report errors/questions that way than to open a new thread in the forums. Also errors are fixed faster when reporting them via forum (with the “report error” button during reviews it takes a looong time until things get fixed)


#533

I’ve noticed a few questions include superfluous hints-borderline-answers following the English sentence, e.g.

犬と散歩を____、UFOを見みた。[する]
/While I was walking/ my dog, I saw a UFO. [verb stem]

The “[verb stem]”, like “While I was walking” is in yellow and remains when the non-yellow portions of the sentence are shown. This seems to me like something that should never be included, as it directly instructs you on how to modify the verb to combine it with the desired grammar. I know I’ve seen this on ながら questions like this one, I can’t say for certain if I’ve seen it anywhere else but I don’t think I have.


#534

@Pushindawood Looks like when it shows the specific reason my answer was wrong, I can’t hit ‘a’ or click anywhere to get the correct answer to display.


#535

Hey, :grin:

We are adding topics for every grammar point and at the same time making sure that higher level grammar is not used at lower grammar points :+1:


#536

Uhmmm… Safari doesn’t have the inspect feature natively. Maybe there is a plug-in (or whatever they are called for Safari nowadays), but I don’t have it. Or is there another way to do this in Safari?

I’m doing N5 grammar. I also checked a lesson whose sentences I’d listened to before and it didn’t work either.

This is what happens: I click the play button, sometimes it gets stuck for a bit here, then the play button becomes the pause button and stripes appear in the audio display as if loading and then bumps me over onto the rewind button without playing any audio. (In fact, it seems like the audio is either 0 seconds or not there.) Clicking the rewind does nothing, except sometimes making the stripes appear in the audio display (as when it is loading).

In reviews the sound just didn’t play.


#537

Great explanation!
It will surely help :slight_smile:

You should be able to access console with Option-Cmd-C shortcut.

By the way, have you tried turning off add blocking extension if you have one (asking just in case)?


#538

Okay, so I turned off ad blocking (which really doesn’t have to be on for this website anyway) and nothing happened. So I moved over to the console stuff and thought I’d make sure I get the cleanest view so I closed Bunpro tabs, cleared all its cache/databases/cookies, and opened it up again. Opened console, went to a lesson, clicked on play and the sound played. :thinking:

So apparently my ad block suddenly started pissing Bunpro off? :confused: Confusing, but I guess it works now.

I did catch that safari found some errors with the console, but they obviously have nothing to do with the sound working or not. Do you want them too?

PS. To make Option-Cmd-C shortcut work, a safari user have to go into Preferences > Advanced and tick the “Show Develop menu in menu bar”. Just in case someone else with Safari needs to find console errors. :blush:


#539

I am glad it helped :grin:


#540

Aaaah, where did the boxes to tick off go in the Readings tab? I loved those since they allowed me to keep track of all the pages I’d already read and taken notes from… It gets confusing after a while!


#541

Actually scratch that. Now audio works when I go with Grammar > Lessons > pick a lesson. The Study feature however is broken; it breaks the audio. It actually breaks the audio for the whole site for me in Safari. (Btw, I have no scripts installed for Bunpro.)

So follow me here:

  1. Cleared all cache/cookies/etc.
  2. Restarted browser.
  3. Sound works for Grammar > Lessons, pick one lesson at a time.
  4. Go to use Study feature because I wanted to do 3 lessons today.
  5. The site sloooows way down. And considering Bunpro is a bit slow most of the time, something was making it worse.
  6. Page loads, I got to example sentence and I click play audio. What I described above happens. No audio plays, doesn’t even seem to be there.
  7. I go to Grammar > Lessons, pick another lessons than before. Audio doesn’t play.

Meaning something in the Study feature is crashing audio on the site. I took out the console and I will post the screenshot below. This also means that I will need to clear cache/etc, and potentially restart my browser again. (Sorry, it is getting a bit old after doing it like 3-4 times in the last 24.)


#542

There is a lot of info here, so I bet that our brave programming team will solve the issue in no time :+1:


#543

I am guessing that whatever the Wiktionary stuff is, that is what is causing the problem. But it is not code from Bunpro. Are there any scripts for other sites or browser wide ones installed that my be trying to run on Bunpro?

@Leilaure The check boxes should still be there.

@powelliptic We are going to be applying some uniform rules to how we give hints and making sure that we fix the hints that borderline give the answer away is one of our top priorities.


#544

As far as I know, no. I’d turned off ad block. Tampermonkey was enabled but have no scripts for Bunpro. So I don’t know what it could be? Here is a list of my extensions in Safari which I assume are the browser wide scripts you might be talking about: Translate 2.1.1 by SideTree (lets me use google translate to translate a tab, I don’t translate Bunpro so supposedly not in use and shouldn’t effect), 1Password (my password manager), Tampermonkey (as mentioned), Safarikai (which lets me get translations and pronunciations of Japanese by highlighting, always off while using Bunpro since I don’t need it), and ABP Control Panel / ABP (aka my ad blocker that is now unenabled on Bunpro).

I just checked, the wiktionary problem only shows up on lesson by lesson pages (aka inside lessons) and on the Study feature (aka inside lessons). I can’t check reviews right now. However, audio still plays if I go lesson by lesson (aka Grammar > lessons). I have not clicked on the Study feature today, because I do not feel like restarting my browser just to be able to use Bunpro with sound.

I clicked the wiktionary error (on a lesson page) to see where it showed up in the debugger and this is what I got:

Also, while the Study feature had 10 errors. Lessons one by one only have 7. So the problem probably lies in one of the three problems only on the study feature. Here is a screenshoot of the errors on the lesson by lesson page:


#545

Thanks for the detailed report!

I looked into it and it looks like that error is being caused by Safari AdBlock. Based on what people said on this thread, it seems like just whitelisting the site doesn’t fix it, you have to disable the add-on itself.

I will look a further into it but there might not be much I can do.


#546

I humbly suggest using uBlock. It is less CPU demanding, and generally it is considered better than any other adblocking app. :+1:


#547

のみならず https://bunpro.jp/grammar_points/601

ナ Adjectives structure should be Na Adj+である+のみらず


#548

I don’t use Safari AdBlock. I use Adblock Plus. But I assume it is still that one.

Does uBlock not mess up Bunpro?