Feedback - Bug Reports


Slight styling issue on a reading link that goes onto two lines.


Bug: saving and updating notes does not always work (Chrome, Android 8). I just realized that many note that I created by copying text from the reading links have not been saved!

Saving and editing plain text from manual input seems to work, but when I paste text from another source then sometimes the notes are not saved!

Same with updating: for example I just updated the “べき” grammar note with content from Tae Kim during review. Than after reviews on the summary screen I clicked on the べき grammar point again and realized that the note was not updated. That seems to be the case for many of my notes :frowning:

Please implement a green message, after notes are successfully generated and updated. So that I can see, if a note was really saved or not.


I‘m not sure here but N3 Level 7 そうもない has an example sentence that want the vocabulary 遊べる.
Isn’t it 遊ぶ? I checked it with multiple dictionaries, but even though some displayed a match for 遊べる the detail page always shows 遊ぶ


Just ignore what I said, it’s the potential form xD


Thank you for your patience as we updated the notes page and ironed out some of the kinks! Bunpro Changelog Cheers!


That looks very nice! But on phones you have to scroll 2 or 3 times to the right in order to see the save and close buttons. These buttons should be the first in the row.


The bug persists. It is not possible for me to save notes during reviews. When I copy content from external sites to the notes field and press “create”, the create button remains yellow and nothing happens. Then the red information appears that the note hasn’t been saved. No matter how often I press create, nothing happens.

And when I manually type in some text and create the note, the green success message is shown. BUT: the note hasn’t been saved and when I visit the grammar point later it’s empty! I think I lost dozens of notes already because of this bug. Please try to fix it as soon as possible.

Besides that, on phones I can’t choose a font since the drop down field is hidden:

(Android 8.1 stock, Chrome)


There an error in the number of reviews when you get one wrong during a session. This image is from when the review I got wrong showed up again at the end.


Same here, I had 4 wrong answers but the counter didn’t add them and stopped at 0. The 4 remaining sentences where shown without any change of the counter


@seanblue @Anthropos888 Looks like that is a bug that got introduced when we added the percentage count. I have it fixed and will update it with the next patch.

@Anthropos888 Is the issue only occurring for you on mobile? I am unable to reproduce the issue on my computer.


I can’t save any notes during reviews. In study\grammar mode I can save it but not during reviews. I only use Android and Chrome so I don’t know if it’s just a mobile problem. I don’t have any extensions or blocker installed, just stock Android and Chrome


Have you tried clearing cache, removing cookies and then logging in again?


Were there some styling changes to the ____ recently? It seems like text is being centered now and it looks really weird with short answers. There’s too much blank space, so the answer isn’t really attached to the words before it. Also, you can kind of see an underline from the text overlaying the ____, which is weird.


Here’s two more pictures to make the issue clear.

Short (partially filled) answer:

Longer answer:

Notice that extra line and noticeable centering in the first picture compared to the second.


@BunproAdmin It looks like you still can’t highlight English sentences during reviews.

Also, there’s a general sentence structure issue throughout the site. Many times when there are parentheses, there is no space before the opening parenthesis. It’s almost like you guys are used to writing in Japanese or something. :stuck_out_tongue:
I would point you to a specific example, but I can’t copy the sentence. :wink: Just something to keep an eye out for. It probably wouldn’t hurt to set up standards for anyone inputting or editing these sentences so they are consistent and as structurally correct as possible.


I, for one, like this change. It’s nice that the space doesn’t collapse when you start typing.

edit: while posting this screenshot in another thread I noticed that it contains a misspelling. Policeman should be plural.


Would this fix the issue for large answers too our just smaller answers? I mostly don’t like the weird underline that shows up below the answer.


Long answers still expand the space as before, it’s just that short ones don’t collapse it


Ah, okay. I understand now.


Yes, I cleared cache and cookies and logged in again. Still the same bug. I can’t create notes during reviews. I have to copy notes to evernote first and then paste them into the grammar points after reviews. Very annoying. I hope you can fix that bug.


Report: Sometimes audio automatically starts to play and cuts off when you enter the correct answer in bunny mode with autoplay enabled.


review count is busted, it only happens recently, it always fluctuative (sometimes it’s suddenly increased by 10 more during reviewing session even though after reloading it shows less again)